Welcome to the Industrial Automation website!

NameDescriptionContent
XING-Automation
E-mail  
Password  
  
Forgot password?
  Register
当前位置:

S7-300 CPU 31xC 和 CPU 31x

F: | Au:佚名 | DA:2023-11-20 | 1405 Br: | 🔊 点击朗读正文 ❚❚ ▶ | Share:

Routing and data record routing

Routing is the transmission of data across network boundaries. Information can be sent from sender to receiver across several networks.

The data logging route is an extension of the common route. For example, when the programming device is not directly connected to the target device

PROFIBUS DP subnets, but when connected to the CPU's PROFINET interface, SIMATIC PDM will make

Record routes with data. The data sent through the data recording route includes parameters of the participating field devices (slave stations)

Configuration, and device-specific information (e.g., set values, limit values, etc.). Data records the destination address structure of the route

Depends on the content of the data, i.e. the secondary station receiving the data.

When a programming device is assigned a different subnet from the target slave station, the data record route can also be read using the programming device

Set of parameters that already exist on the field device, edit them, and return them to the field device.

The field devices themselves do not need to support data record routing because they do not forward the received information.

Clock synchronization

1:intro

The CPU interface supports clock synchronization. The CPU can be programmed to act as a time master (with a default synchronization interval)

Interval) or time to run from the station.

Default value: No clock synchronization

Set synchronization mode

In the properties dialog box of HW Config, set the synchronization mode as follows:

In AS (on the central I/O bus) : Tab → Diagnostics/Clock (Tab → Diagnostics/Clock)

(Also applicable to MPI on CPU without DP interface)

● For MPI/DP or DP interface: Tab → Clock

● For PROFINET interface: Tab → Clock synchronization


2: interface

The following interfaces support clock synchronization:

● MPI interface

The CPU can be configured as either a time master or a time slave.

● DP interface

The CPU can be configured as either a time master or a time slave.

● PROFINET interface

The clock is synchronized with the CPU on the client through NTP.

● On the automation system in the central rack

The CPU can be configured as either a time master or a time slave.

Instructions

On many of these interfaces, the CPU cannot be used as a time slave.

CPU as time slave station

When acting as a time slave, a CPU receives synchronization frames only from a time master and uses that time as an internal time for that CPU

Between.

The CPU serves as the time master

When acting as a time master, the CPU broadcasts clock-sync frames at set synchronization intervals to synchronize them in the subnet to which they are connected

It stands.

Requirement: The CPU clock is no longer in the default state. The clock must be set at least once.

Clock synchronization as a time master begins with:

● After this time is initialized by SFC 0 "SET_CLK" or programming device function

● Use another time master, provided that the CPU is also programmed as an MPI/DP or PROFINET interface

Time operates from the station.

Instructions

The real-time clock of the CPU is not set in the following cases:

 before delivery

 after the mode selector switch is reset to factory Settings

 After firmware update

3. Point-to-point connection

Stats:

Point-to-point connections allow data to be exchanged over serial interfaces. Point-to-point connections can be used to interconnect programmable controllers, computations

Computer or third party system with communication function. It can also be adjusted according to the procedures of the communication partner.

3.1 Data Consistency

Stats:

A data area is consistent if it can be read or written to in the operating system as a block. Station to station

The data exchanged centrally between them should belong to a whole and originate from a processing cycle, that is, the data is consistent. If user

Programs that include programmed communication capabilities (for example, using XSEND/XRCV to access shared data) can pass

The "BUSY" parameter itself coordinates access to the corresponding data area.

Use the PUT/GET function

For some S7 communication functions that do not require blocks in CPU (server mode) user programs (e.g.,

In terms of PUT/GET or write/read access via OP communication, the scope of data consistency must be considered during programming.

The PUT/GET function of the S7 communication or the read/write variable operation through the OP communication are executed at the cycle control point of the CPU

Fine. To guarantee the defined hardware interrupt response time, the communication variables need to be in the form of blocks of up to 240 bytes, to/from

The copied user memory in the operating system loop control point is continuously copied. There is no guarantee for larger data areas

Data consistency.

Using PUT/GET functions and "Prioritized OCM communication"

If the operation is configured as "OCM communication by priority", the specified data consistency is lost (see the chapter "OP Communication (page 80)"). Therefore, data consistency must be ensured through user programs.

Keep the following consistent:

● Byte, word, double-word access (e.g. LMDx)

● SFC 14 "DPRD_DAT"

● SFC 15 "DPWR_DAT"

SFC 81 "UBLKMOV" (for copying up to 512 bytes of data)

It should also be understood that if OCM Communication by Priority is configured, the communication will not be changed at the loop control point

Quantities are continuously copied to/from working memory in blocks of up to 240 bytes. Therefore, it should be done while the user program is running

Copy the data.

                                                                                    Quantity name

                                                                                    ① Analog input and analog output

                                                                                    ② Digital input

                                                                                    ③ digital output

3.2 SNMP Communication Service

availability

SNMP V1, MIB-II communication services can be used with integrated PROFINET interfaces and using version 2.2 or later

Firmware for the CPU.

Stats

SNMP (Simple Network Management Protocol) is the standard protocol for TCP/IP networks.

3.3 Open communication over Industrial Ethernet

demand

● Since STEP 7 V5.4 + SP4

Feature

Cpus with integrated PROFINET interfaces support over industrial Ethernet starting with firmware V2.3.0 or V2.4.0

Open communication function (referred to as: Open IE communication)

Open IE communication provides the following services:

● Connection-oriented protocols

- TCP compliant with RFC 793, connection type B#16#01, firmware V2.3.0 and later

- TCP compliant with RFC 793, connection type B#16#11, firmware V2.4.0 and later

- ISO-on-TCP compliant with RFC 1006, firmware V2.4.0 and higher

● No connection protocol

- UDP compliant with RFC 768, firmware V2.4.0 and later

Attributes of the communication protocol

The following protocol types are included in data communication:

● Connection-oriented protocols:

These protocols establish a (logical) connection to a communication partner before the data transfer and then after the transfer is complete

The connection needs to be closed. When the security of data transmission is particularly important, connection-oriented protocols are used. Usually pass

Multiple logical connections can be established over a single physical cable.

FB for open communication over "Industrial Ethernet" supports the following connection-oriented protocols:

- TCP compliant with RFC 793 (connection types B#16#01 and B#16#11)

- ISO-on-TCP according to RFC 1006 (connection type B#16#12)

● No connection protocol:

These protocols can work without establishing a connection. This means there is no need to establish and terminate connections to remote partners

Answer. Connectionless protocols do not require confirmation to transmit data to remote partners; Therefore, data transmission is not secure.

FB for open communication over industrial Ethernet supports the following connectionless protocols:

- UDP compliant with RFC 768 (connection type B#16#13)


How to communicate with Open IE?

To allow the exchange of data with other communication partners, STEP 7 provides the following FB and under Communication Blocks in the Standard Library

UDT:

● Connection-oriented protocols: TCP, ISO-on-TCP

- FB 63 "TSEND" for sending data

- FB 64 "TRCV" for receiving data

- FB 65 "TCON" for connection

- FB 66 "TDISCON" for disconnection

- UDT 65 "TCON_PAR", whose data structure allows the connection to be parameterized

● No connection protocol: UDP

- FB 67 "TUSEND" for sending data

- FB 68 "TURCV" for receiving data

- FB 65 "TCON" for establishing local communication access points

- FB 66 "TDISCON" for parsing local communication access points

- UDT 65 "TCON_PAR", whose data structure can be parameterized to local communication access points

- UDT 66 "TCON_ADR" with remote partner addressing parameter data structure

Operator controls and indicators for CPU 313C-2 DP

                                                                                            Quantity name

                                                                                            ① Status and error indicators

                                                                                            ② Slot of SIMATIC MMC card (including eject device)

                                                                                            ③ Integrated input and output terminals

                                                                                            ④ Power connection

                                                                                            ⑤ 2. Interface X2 (DP)

                                                                                            ⑥ 1. Interface X1 (MPI)

                                                                                            ⑦ Mode selector

A block of data for parameterization

A block of data for parameterizing TCP and ISO-on-TCP connections

To use TCP and ISO-on-TCP configuration connections, you need to create a number that contains UDT 65 "TCON_PAR" medians

According to the structure of DB. This data structure contains all the parameters needed to establish the connection. Each connection requires such a number

According to the structure, you can arrange it in the global data store.

The CONNECT parameter of FB 65 "TCON" contains a reference to the address of the corresponding connection description (e.g.,

P#DB100.DBX0.0 Byte 64).

A block of data used to parameterize local communication access points using UDP

To assign parameters to the local communication access point, create one that contains the UDT 65 "TCON_PAR" data structure

DB. This data structure contains the parameters needed to establish a connection between the user program and the communication layer of the operating system

The CONNECT parameter of FB 65 "TCON" contains a reference to the address of the corresponding connection description (e.g.,

P#DB100.DBX0.0 Byte 64).

Instructions

Setting Connection Instructions (UDT 65)

You need to enter the communication interface in the "local_device_id" parameter of UDT65 "TCON_PAR" (for example

B#16#03: Communication via IE interface integrated with CPU 319-3 PN/DP).


Establish communication connection

● Suitable for TCP and ISO-on-TCP

Both communication partners call FB 65 "TCON" to establish a connection. Define which communication partner is used as master during parameterization

Dynamic communication endpoints and which are used as passive communication endpoints. To determine the number of possible connections, see your CPU's technology

The technical specifications.

The CPU automatically monitors and maintains active connections.

If the connection is interrupted, for example due to an open circuit or a telecommunication partner, the active party will attempt to re-establish the connection

Answer. You don't have to call FB 65 "TCON" again.

The active connection is terminated by calling FB 66 "TDISCON" or when the CPU is in STOP mode. Want to re-

To establish a connection, you must call FB 65 "TCON" again.

● Suitable for UDP

Both communication partners call FB 65 "TCON" to set up their local communication access point. This will be in the user program and operation

Connections are established between the communication layers of the system. Connections to remote partners are not established.

The local access point is used to send and receive UDP packets.

Distinguish between PROFINET IO and PROFINET CBA features

                                           PROFINET IO and CBA represent automation equipment for "industrial Ethernet" from two different perspectives.

Component-based automation divides the entire device into different functions. These functions are configured and programmed separately.

The device view provided by PROFINET IO is very similar to the PROFIBUS view. You can continue to configure and configure individual programmable controllers


  • National Instruments USB-6363 DAQ Device
  • National Instruments NI 9467 GPS Module
  • National Instruments USB-6351 DAQ Device
  • National Instruments NI 6581 Adapter Module
  • National Instruments 781045-01 Output Module
  • National Instruments PCI-6225 DAQ Card
  • National Instruments TRC-8543 CAN Cable
  • National Instruments PXIe-1073 Chassis
  • National Instruments USB-6003 DAQ Device
  • National Instruments NI 9476 Output Module
  • National Instruments myRIO-1900 Embedded Controller
  • National Instruments NI-9263 Analog Output Module
  • National Instruments 158561A-01L Ordering Part Number
  • National Instruments 785024-01 Ordering Part Number
  • National Instruments PCI-6510 Industrial Digital I/O Card
  • National Instruments USB-6259 Multifunction DAQ Device
  • National Instruments USB-8452 I2C SPI Interface Device
  • National Instruments PXI-8432 Serial Interface Module
  • National Instruments PXIe-5644R Vector Signal Transceiver
  • National Instruments PXI-2569 Relay Module
  • National Instruments 781174-01 Module
  • National Instruments 782000-01 Module
  • National Instruments PXI-5152 Digitizer
  • National Instruments PXI-6284 DAQ Card
  • National Instruments PCI-1428 Frame Grabber
  • National Instruments PXI-1050 Chassis
  • National Instruments NI USB-8486 Fieldbus
  • National Instruments NI 9862 CAN Module
  • National Instruments NI 9146 FPGA Chassis
  • National Instruments PXI-8108 Controller
  • National Instruments NI SWB-2816A Matrix Module
  • National Instruments NI 9269 Analog Output Module
  • National Instruments PCI-6031E Multifunction DAQ Card
  • National Instruments PXI-6713 Analog Output Module
  • National Instruments NI 9216 RTD Input Module
  • National Instruments NI-9237 Strain Bridge Input Module
  • National Instruments PXI-5124 High Resolution Digitizer
  • National Instruments USB-6343 X Series DAQ Device
  • National Instruments PXIe-6536 Digital I/O Module
  • National Instruments CAL-4330 Calibration Fixture
  • National Instruments PXI-4110 Programmable Power Supply
  • National Instruments 781503-01 Input Module
  • National Instruments FP-AI-V10 Module
  • National Instruments PXI-5114 Digitizer Card
  • National Instruments PXIe-8398 MXI Module
  • National Instruments cRIO-9056 Controller
  • National Instruments PCI-6509 DIO Device
  • National Instruments cRIO-9053 Controller
  • National Instruments 781056-01 Output Module
  • National Instruments 782606-01 Input Module
  • National Instruments cRIO-9112 Chassis
  • National Instruments PXIe-1078 Chassis
  • National Instruments PCIe-6536 DIO Board
  • National Instruments NI-9425 Input Module
  • National Instruments PCI-5122 Digitizer Card
  • National Instruments 779072-01 Relay Module
  • National Instruments 783703-01 DAQ Module
  • National Instruments PXI-6515 Digital Module
  • National Instruments 781099-01 DAQ Device
  • National Instruments PXI-8183 PXI Controller
  • National Instruments sbRIO-9626 Single-Board RIO Controller
  • National Instruments PXIe-1435 Camera Link Frame Grabber
  • National Instruments NI 9237 Strain Bridge Input Module
  • National Instruments PXIe-4353 Thermocouple Input Module
  • National Instruments PCIe-6320 X Series DAQ Card
  • National Instruments NI 1454 Compact Vision System
  • National Instruments PCIe-6321 X Series DAQ Card
  • National Instruments PXIe-5172 PXI Oscilloscope Module
  • National Instruments cDAQ-9134 CompactDAQ Controller
  • National Instruments cRIO-9063 CompactRIO Controller
  • National Instruments PXI-4070 DMM Card
  • National Instruments cFP-BP-4 Backplane
  • National Instruments 779521-01 Bridge Module
  • National Instruments cDAQ-9172 Chassis
  • National Instruments NI 9236 Strain Module
  • National Instruments PXI-1042Q Chassis
  • National Instruments SCXI-1102 Input Module
  • National Instruments 776990-01 Input Module
  • National Instruments PXI-1045 PXI Chassis
  • National Instruments PCIe-6251 DAQ Device
  • National Instruments NI 9219 Universal Analog Input Module
  • National Instruments NI 9215 BNC Analog Input Module
  • National Instruments PXIe-6570 Digital Pattern Instrument
  • National Instruments NI-9477 Digital Output Module
  • National Instruments NI 9145 EtherCAT Chassis
  • National Instruments PCI-6521 Industrial Digital I/O Card
  • National Instruments NI 9239 BNC Voltage Input Module
  • National Instruments NI 9265 Current Output Module
  • National Instruments NI 9212 Thermocouple Input Module
  • National Instruments PXI-6229 Multifunction DAQ Module
  • National Instruments NI-9146 Chassis
  • National Instruments PXIe-5622 Digitizer
  • National Instruments PXI-6704 Output Module
  • National Instruments 782362-01 Input Module
  • National Instruments 779068-01 Digital Module
  • National Instruments 781063-01 Output Module
  • National Instruments PCI-7356 Motion Controller
  • National Instruments 779787-01 Input Module
  • National Instruments PXIe-1071 System
  • National Instruments NI 9219 Input Module
  • National Instruments NI 9214 Thermocouple Input Module
  • National Instruments PXIe-1085 18-Slot Chassis
  • National Instruments PCIe-6320 Multifunction DAQ Card
  • National Instruments USB-6211 Multifunction I/O Device
  • National Instruments USB-6341 X Series DAQ Device
  • National Instruments NI 9205 Analog Input Module
  • National Instruments NI 9149 8-Slot Chassis
  • National Instruments PXIe-2569 Relay Module
  • National Instruments NI 9230 Sound and Vibration Module
  • National Instruments cRIO-9047 CompactRIO Controller
  • National Instruments PCI-6534 Digital IO Card
  • National Instruments PXI-5122 Digitizer Module
  • National Instruments cDAQ-9188XT Chassis
  • National Instruments cDAQ-9184 Ethernet Chassis
  • National Instruments USB-6225 OEM DAQ Device
  • National Instruments NI 9205 Input Module
  • National Instruments NI 9207 Input Module
  • National Instruments NI-9862 CAN Module
  • National Instruments 781156-01 CAN Module
  • National Instruments FP-AO-200 Output Module
  • National Instruments NI 9264 Output Module
  • National Instruments IC-3173 Controller
  • National Instruments NI 9234 Vibration Module
  • National Instruments SMB-2163 DIO Accessory
  • National Instruments PXIe-1062Q DSA System
  • National Instruments USB-6289 DAQ Device
  • National Instruments NI 9233 Vibration Module
  • National Instruments PXIe-5840 VST